All Products Support

BioDiscovery does not support the use of proprietary file formats. Rather, BioDiscovery has adopted the use of tab delimited text files. Microsoft Excel files can easily be saved as tab delimited text files as outlined below. To save an Excel Doc as Tab Delimited Text:

  1. With the Excel document open, choose Save as… from the File Menu.
  2. Select Text (Tab Delimited) from the Save as Type Option at the bottom of the Save as Window.
  3. Specify a File name and location.
  4. Click Save.
  5. Microsoft will warn that certain elements cannot be saved in this format. Simply accept any warnings to complete the process.
  6. For additional information on the required text format, please see the documentation accompanying the software.

All BioDiscovery products are written in Java. Java can only see drive letters, not network locations. Therefore, the simplest solution is to map a network location to a drive letter. Under Windows, you can browse the network, right-click on the folder that contains the files and select Map Network Drive. Map it to a letter that is not being used by anything else (like “N” for Network or whatever you want). Then, when the BioDiscovery software asks for a file, simply select the N: drive and it will load the files across the network without transferring them locally first.

The  permissions are set up correctly by our software when you install it,  but only if you are using an account that has administrative privileges.  You can always un-install and re-install using an account that has  administrative privileges. If you need further assistance, please contact Support.

BioDiscovery software has been cited in hundreds of publications. Please use the full name of the software (e.g., Nexus Copy Number Discovery), the publisher (BioDiscovery, Inc.), and the URL when citing. The following is an APA style example of how to cite BioDiscovery software. The example uses Nexus Copy Number 9.0 Discovery.

BioDiscovery, Inc., Nexus Copy Number Discovery Version 9.0. El Segundo, CA: BioDiscovery, Inc. Available from http://www.biodiscovery.com.

For a complete list of publications click here.

NxClinical Support

NxClinical is a platform-independent and comprehensive software solution for genetic data analysis, interpretation, management, and reporting for molecular genetics and cytogenomics labs.

The data loaded into NxClinical is stored in a central database repository and can therefore be accessed from any location. The repository can be located within an institution’s network or on external cloud-based servers – the customer chooses where to house the data.

Yes, multiple people can access the same data concurrently as all data is stored in a single central repository. Users can view the same sample at the same time from different locations, and when a user wants to make changes, the sample goes into edit mode and locks, preventing other users from making changes at the same time. Other users can continue viewing the data but cannot make changes. Once the first user has finished making changes, the changes are immediately visible to other users and another user can now edit the sample.

NxClinical is a comprehensive system which allows loading of raw probe-level data to segment and make calls and assists in interpretation of the results. The ability to visualize raw probe-level data along with calls and classification in a single software allows for immediate confirmation of events. The NxClinical software replaces multiple software systems performing different functions and streamlines the entire process from processing of raw data to generation of reports.

As NxClinical is an enterprise product we do not have a demo license as we do for the desktop product Nexus Copy Number. For more information on NxClinical and to get demo, please fill out the form here.

Algorithms are set; version changes indicate implementation of new features in the product Release Notes.

Unlimited; the only constraints are on the physical space and speed of the main server.

There are many public databases available including ClinGen/ClinVar, OMIM, DECIPHER, Imprinted Genes (Gene Imprint), Segmental Duplications (UCSC), and CIViC . Custom tracks you design and other public databases are available upon request.

The NxClinical Administrator at your site can add custom tracks to the visual display and table. Each user can configure this further to hide/show the available content.

Yes. The NxClinical Administrator at your site will need to set this up with assistance from BioDiscovery Support.

NxClinical is technology and platform agnostic. It handles both microarray and NGS data. Major manufacturers such as Illumina, Thermo Fisher (Affymetrix), Agilent, etc. are supported as well as custom platforms. You can load and analyze data from any manufacturer/platform in the same database.

Nexus Copy Number Support

Nexus Copy Number is a desktop software program for analysis of DNA copy number variation from aCGH, SNP array, and NGS data. In a user-friendly and efficient fashion, it allows users to detect the segments of DNA that have been lost or amplified and to detect allelic event changes (e.g. LOH). Sequence variants and gene expression results can also be loaded and analyzed alongside copy number variants.

Nexus Copy Number supports virtually any aCGH, SNP array, or NGS platform, such as Affymetrix, Agilent, Illumina, custom arrays, Illumina HiSeq/MiSeq, Ion Torrent, Complete Genomics and more as well as data generated by various array image analysis software tools such as GenePix and ImaGene.

Copy number can be estimated (via BAM files) from whole-genome, whole-exome, and targeted NGS panels and associated sequence variants (typically via VCF and MAF files) can be visualized and analyzed. Nexus Copy Number also integrates single sample gene expression results to provide a complete genomics solution.

Absolutely. Data from any number of different vendors (e.g. Illumina, Affymetrix, Agilent) and different technologies (e.g. aCGH/SNP microarray, WES, WGS) can be integrated, visualized, and analyzed together in Nexus Copy Number.

Yes, Nexus allows you to load sequence variants typically as VCF or MAF files. Custom files can also be loaded. Sequence variant data is uploaded via the Seq. Variation tab in the Load Data pop-up window. These variants can be viewed and analyzed alongside copy number variations.

Yes, copy number can be estimated (via BAM files) from whole-genome sequencing (WGS), whole-exome sequencing (WES), and targeted NGS panels in Nexus Copy Number software.

Data from virtually any organism can be used within Nexus. You just need to have the genome annotation files in the installation directory. The product comes only with human and mouse annotations but you can add any other organism. If your organism is not listed, we can generate the files for you.

Yes. Nexus Copy Number allows you to incorporate miRNA, mRNA, and RNASeq results on a per sample or cohort basis to identify genomic hot spots.

Yes. Nexus Copy Number allows you to incorporate external methylation data to identify genomic hot spots.

An  unlimited number of samples can be analyzed together. Some of our  customers have used several thousand very high-density arrays in a  single project on a typical desktop computer.

The highest density arrays that are available on the market can be used. Nexus Copy Number can efficiently process the Illumina HumanOmni5-Quad arrays with 5 million probes or the Affymetrix CytoScan HD array with 2.6 million probes.

Preferred:
64-bit Platforms – Windows/OSX/Linux; Recommended: 4 GB RAM; Minimum: 2 GB RAM

Supported:
32-bit Platforms – Windows Win2k/WinXP/Win7; Recommended: 2.0 GHz or faster, 4 GB RAM; Minimum: 1.0 GHz Pentium, 2 GB RAM

You simply select files you want to load using the file chooser and then click on the Load Data button to load the data. In rare cases such as when loading dye-swap data or replicate data, you will create a Sample Descriptor (a tab de-limited text file) which will specify the sample types and files to load. Individual data type quick start guides (e.g. “Nexus Copy Number Quick Sheet for Affy CEL”, “Nexus Copy Number Quick Sheet for Illumina Using Plugin”) in PDF format are available in the docs folder of your Nexus installation folder. Please view the document specific for the type of data you are loading.

Yes. Nexus can quickly identify regions of genomic change that can distinguish between two populations (e.g. affected and unaffected individuals) and provide statistical confidence measure for each region.

Nexus Copy Number offers the following algorithms for making segmentation calls.

  • Rank Segmentation: A robust variation of the well-known Circular Binary Segmentation (CBS) algorithm where the probe ranks are used to minimize the effect of outliers and drastically improve performance.
  • SNPRank Segmentation: An extension of the Rank Segmentation algorithm where B-Allele Frequency values are also included in the segmentation process generating both copy number and allelic event calls.
  • FASST2 Segmentation: A novel Hidden Markov Model (HMM) based approach that unlike other HMM methods does not aim to estimate the copy number state at each probe but uses many states to cover possibilities, such as mosaic events, and then make calls based on a second level threshold.
  • SNP-FASST2 Segmentation: An extension of the FASST2 algorithm but adding many more states to cover events related to the B-Allele Frequency values to make copy number and allelic event calls.

Yes. Nexus Copy Number allows you to bring copy number data that has already been segmented for further processing.

The Nexus DB account request needs to be initiated from within the Nexus application. After launching Nexus, click on the “Login to Nexus DB” icon or click on “Nexus DB” in the menu bar and select “Login to Nexus DB.” In the resulting window, click on the blue “Register account” link (bottom left), fill in your information, and submit the form. You will receive your account username and password within two business days. Once you have your account, you can log into Nexus DB and query or browse the available projects. For further information on access, querying, uploading, downloading data to/from Nexus DB, please refer to the section on Nexus DB in the User Manual.

Yes. Some popular commercial oligo-array manufacturers supported by Nexus Copy Number include Affymetrix, Agilent, and Illumina.

In case of memory allocation issues with the BAM Multiscale Reference Builder utility while creating the reference file for the BAM (multiscale reference) data type:

It is recommended to increase the memory allocated to the Multiscale BAM Reference Builder to about 50% of total memory available; at minimum the reference builder requires 4GB of memory.

For PCs:
Edit the “MultiScale BAM Reference Builder.lax” file in the installation directory. E.g. for win64 machines, to increase the memory to 8GB, edit the -Xmx parameter in the following line to 8000m:

lax.nl.java.option.additional=-Xms500m -Xmx8000m

For MACs:
Edit the .plist file for the MultiScale BAM Reference Builder application to increase memory allocation to about 50% of total memory. E.g. if you have 16GB memory, change the -Xmx value to 8000m. e.g. from

<string>-Xmx4000m<string>

to

<string>-Xmx8000m<string>

For all other memory issues, follow the instructions below.

For 64-bit PCs:
Try increasing the space allocation by editing the file C:\Program Files\BioDiscovery\Nexus 9\nexus 9.lax increasing the parameter -Xmx in the line below. If you have 8gig of RAM, then change the Xmx parameter to 4000m (4g), about half the RAM on your computer. E.g. from

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m -Xmx2200m -Dnl_floating=undefined -Dnolock=true

to

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m –Xmx4g -Dnl_floating=undefined -Dnolock=true

For MACS:
Please go to /Applications/BioDiscovery/Nexus 9 and ctrl-click on Nexus 9.app and select the option “Show Package Contents.” Open the Contents folder and open info.plist with TextEdit to increase the memory allocation to about 75% of the total RAM on your computer.

For example if you have 8 gigs of RAM then change the –Xmx parameter between array tags (line depicted in bold) from

<array>
<string>-Xms32M<string>
<string>-Xmx64M<string>
<string>-Xms500m<string>
<string>-Xmx2500m<string>

To

<array>
<string>-Xms32M<string>
<string>-Xmx64M<string>
<string>-Xms500m<string>
<string>-Xmx6g<string>

Save the file and restart Nexus Copy Number. This increases memory allocation to 6gigs.

For 32-bit PCs:
Please go to the folder C:\Program Files\BioDiscovery\Nexus 9.0\ and edit the file Nexus 9.0.lax in Notepad, and change the -Xmx value in the following line from

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m –Xmx800m -Dnl_floating=undefined -Dnolock=true

to

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m –Xmx1100m -Dnl_floating=undefined -Dnolock=true

Save the file and restart Nexus Copy Number. This increases memory allocation to 1100 mbs which is a max for 32-bit computers.

For 32-bit PCs that show error message “Cannot start Java virtual machine”:

Please go to the folder C:\Program Files\BioDiscovery\Nexus 9.0\ and edit the file Nexus 9.0.lax in Notepad, and change the line:

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m –Xmx1200m -Dnl_floating=undefined -Dnolock=true

to

lax.nl.java.option.additional=-XX:-UseGCOverheadLimit -Xms500m –Xmx1000m -Dnl_floating=undefined -Dnolock=true

Save the file and restart Nexus Copy Number. This decreases memory allocation to 1000 mbs which will allow java to start up.

Nexus Expression Support

Nexus Expression is a platform-independent and user-friendly software solution for gene regulation analysis from commercial or custom RNASeq and microarray platforms.

Nexus Expression supports data from multiple different vendors and platforms. But unlike Nexus Copy Number, in Nexus Expression you can only load one array/platform type in a single project.

You can combine data from multiple projects as follows:

  • After doing a comparison in one project, click on “Export Diff. Ref.lists” and save this file.
  • Open the exported file and delete the first column with header=Probe and save the file as a tab-delimited text file. Nexus Exp will try to match the probe-ids if the Probe column exists and since you will be adding to a different project the probe-ids will not match.
  • Open the second project and go to the Probes tab and click on “Add Probe List” and select the edited file. This will create a new column with values up/down for matching Gene symbols. You can sort by this column to look for genes commonly regulated between the two projects.

It tries to measure the overall similarity between a given gene/probe to other ones across all selected samples essentially trying to see if things are co-regulated. The measure is what is used to measure similarity for clustering genes (under the Options menu) and typically Pearson Correlation. So a score of 1 would be most correlated and -1 would be the exact opposite.

ImaGene Support

Typically, when ImaGene stops processing in the middle of analysis, there is an insufficient amount of memory to continue. The simplest remedy is to the open the ImaGene.properties file located within the ImaGene\Jexpress  folder and increase the -mxXXXm value. This value can be set up to approximately -mx1024m (1024 MB). Please note that while this change may allow analysis, without enough matching physical RAM in the computer  performance will be greatly diminished.

The ability to run batches is controlled by the BatchUsers.txt file. This file contains all the names of users who are eligible to run ImaGene in batch mode on that particular computer. The location of this file is within the data\imagene directory inside Java Home. Typically, this location is: C:\Program Files\JavaSoft\JRE\1.3\data\imagene although the exact location depends on installation selections. The usernames contained within this file must be the usernames used to login to the computer. For example, if John Smith logs into his computer as jsmith, then BatchUsers.txt must contain the entry jsmith. If multiple users log into this computer and they wish to run ImaGene in batch mode, then either all usernames must be entered or the use of the keyword anyone is also permitted. The keyword anyone permits all users to operate ImaGene in batch mode. In environments where numerous users exist and/or security is important, Administrators are encouraged to set file privileges on BatchUsers.txt to limit its modification.

You must have the file “license.dat” in the same directory as the ImaGene executable. Also, be certain the file netlicense.txt contains the  correct path to the imagene.ini license file.

When ImaGene opens images for analysis, it reads information contained within the image file that explains which pixels represent high and low intensities. Users often assume that the visually white pixels always represent high values; however, this may or may not be the case depending on the information provided within the image file.  The problem is that there are times when the image generation software does NOT include information describing what values white and black pixels should represent. The result is that ImaGene displays this information “backwards”, meaning what the user expects to contain high values in reality is being displayed with the inverse value. ImaGene provides a handy solution to this problem. On the Main User Interface, located under the Image Tab, is an Invert Checkbox. Select this checkbox to invert the value of pixels within the image. Visually, the image will “flip” causing high and low-intensity pixels to change in the image window. Note: Selecting the Invert Checkbox truly inverts the values of the images which is reflected in the quantified data files. To “flip” the view only for visual purposes, not affecting the quantified values, only select the Reverse Display Image Checkbox located at the  bottom of the Image Tab.

The Preview Window allows users to see the results of segmentation prior to quantifying an image or images. The purpose of this window is to be certain that the proper settings have been established so that ImaGene removes contamination, such as dust, properly. ImaGene uses patent-pending statistical methods to determine whether individual pixels belong to the signal or background regions. Green represents pixels that will be used in calculating a background value. Red represent pixels that will be used in calculating a signal value. Pixels that are neither red nor green are ignored and thus not used in the calculation of mean, median, etc values. Ultimately, the Preview Window helps user establish optimal parameters ensuring high quality, consistent data.

Spot circles are colored using gradual scale from blue to red, with blue indicating no contamination and red indicating that contamination is present. If both signal and background contamination confidence tests are chosen,  the colors represent the equally weighted sum of two confidence values.  If one test is selected, then only that result will define the coloring.

These are quanitification flag markers:

  • X = empty spot
  • + = poor spot
  • – = negative spot
  • Red = manually selected
  • Green = selected by parameters

In ImaGene 8 and prior versions had both a template (.tpl file) and a grid (.grd file). A template was composed of both a grid and a GeneID file. A grid was only the geometry of the array without any clone information. In ImaGene 9, templates (.tpl files) have been replaced with a newer format of grids (.grd files). Grid files in version 9 are composed of both the array geometry and GeneIDs. When using a .tpl file or a .grd file from older versions in ImaGene 9, it is necessary to first convert the files to a .grd file using the Grid/Template Converter Utility. This utility can be downloaded here.

The SST file produced by ImaGene is a proprietary, binary file containing information about the processing that has occurred. The SST file is used by ImaGene to review the VISUAL results of previous image processing. The SST file contains information about segmentation, quality measures, grid placement and other data generated as a by product of processing. The SST file allows ImaGene to reload and consequently display VISUAL indicators of previous processing. Since the SST file is only necessary to review the visual results of processing, users who are only interested in the quantified values (mean, median, etc) can simply delete this file. ImaGene always generates standard text files with the quantified values for each image processed. This means that the text data files are saved and used for later analysis in such products as GeneSight. The SST file is not designed to be loaded into GeneSight or any other data analysis software packages. The information contained within the SST file is of no value to other programs. The SST file can often grow quite large in size, often times becoming larger than the original image. This is common and is due to the amount of visual information and quality measures contained within. The SST file aids Flex Pack and Automation module users the most as it allows for easy review of Batch Processed Images. For additional information on the SST file, please consult your ImaGene documentation.

ImaGene Premium comes with an optional Automation Module that allows the quantification of multiple images in a batch. This allows time-consuming quantification to be performed automatically during time when the computer is not being used by researchers.

  • Negative Spot = signal is lower than ambient background (usually a bad thing)
  • Empty Spot = signal is equal to ambient background (or very close)
  • Good Spot = singal is higher than ambient background

Tiff – (*.tif) Bas – (*.inf, *.bas, *.img) Gel – (*.gel)  Currently, there are no plans to add additional formats.

Each value corresponds to a different type of flag. These flags are represented visually on your quantified data display by different markers.

0 = No Flag (no marker)
1 = Manual Flag, No Type (red X)
2 =  Auto-Flag, Empty Spot (green X)
3 = Auto-Flag, Poor Spot (green +)
4 =  Auto-Flag, Negative Spot (green -)
5 = Manual Flag, Empty Spot (red X)
6  = Manual Flag, Poor Spot (red +)
7 = Manual Flag, Negative Spot (red -)

This phenomenon puzzles users and makes them redo spot finding again and again. In fact, the grid circle only shows where the image spot is and it does not have to cover the entire spot. After quantification, go to the segmentation tab for each image (image name seg tab) to check the segmentation of each spot. As long as the red segmentation line covers each spot, the spot finding works.

The wrangle feature of ImaGene applies new, stricter constraints to the results of spot localization without requiring further spot finding.  Essentially, this allows users to reduce the spot search radius without redoing the spot finding. The benefit of this feature is to assist processing for those with either slower computer hardware or for those with numerous spots.  A sample application would be to perform spot finding for a grid geometry on an array image with a local flexibility set a large number of pixels. After spot finding, if the resulting circle placement has high variability, the Local Flexibly can be reduced. After reducing Local Flexibility, click the Wrangle Button to apply the new setting  without waiting for spot finding to be performed again.  Most users with recent computer hardware need not employ this feature as it has become largely unnecessary.

The min. and max. diameters of image spots affect the grid placement and spot finding, and in turn affect the segmentation. For this reason, it is important to get a relatively accurate measurement before creating a  grid. It is better to zoom up a group of smallest or largest spots, measure them using the ruler tool, and take the average. Usually, within 2 to 3 pixels in accuracy is good enough.

There is no fixed number here. Normally, one click of the Auto Adjust Spots icon is enough. But you can do it a few times if you do not like the results.

Local Flexibility defines the radius, measured in pixels, that ImaGene is allowed to search for spots. The origin for the search is the initial  spot location as determined by grid placement. Usually, a value of 3 – 5  pixels is the typical setting. Global Flexibility is an indication of the extent to which ImaGene should deform the grid to match a given set  of spots. Most users should set sliding bar to the middle.

Select the magnification tool and double right-click.

ImaGene has been designed from the beginning for muti-channel analysis. In fact, the number of images that can be processed is limited mainly by  the amount of memory present within the computer.

There is no fixed limit. You should have at least a 10 levels on a system that meets our minimum requirements, but the actual amount will vary depending on the RAM of your system.

Each  input file must have a separate name, otherwise the output file will be written twice (the 2nd image data overwriting the first). For example, C:\Test1\MyData.tif and C:\Test2\MyData.tif would result in  only a single “MyData.txt” file (with only the C:\Test2\MyData.tif  results).

The  .sst file contains links to the images that generated it. These links are the absolute paths to the images. By default, ImaGene will attempt  to load the images from the location specified within the sst file.  However, if the images have been moved and ImaGene is not able to load them, ImaGene will prompt the user to browse to and select the appropriate images.

Image processing in ImaGene is very straightforward and normally only takes a  few steps. If the images are in good quality, the steps are: Loading  images, Creating and placing grid, loading Gene ID file, Clicking the  Automatically place grid button, Clicking the Auto Adjust Spots button,  Quantification, Saving results.  Of course, user has to spend some time to set the right configuration  parameters in ImaGene Settings before doing image processing. Sometimes  when the images are not of good quality, the user also has to manually  adjust the grids or spots for portions of the images.

Can't Find What You're Looking For?

Fill out a Support Request and our knowledgeable staff will be here to help as soon as we can.

Request Support